Warning

I have a certification exam next week, should I upgrade?

Windows

Video tutorial

Mac OSX

Linux

Ubuntu / Debian from 1.5

Ubuntu / Debian from 2.0 release

GNS3 VM

Last updated
May 3, 2017

Contributors
Julien Duponchelle
Mark Blackwell
Last updated
May 3, 2017

Contributors
Julien Duponchelle
Mark Blackwell

Upgrade to GNS3 2.0

Warning

No rollback is possible. Backup all your projects, settings and snapshot the GNS3 VM.

If you still have project created with 0.8.x open them with a 1.X version of GNS3 before switching to 2.0. No direct conversion from 0.8 to 2.0 will be supported.

I have a certification exam next week, should I upgrade?

NO! Upgrade only if you are not in the middle of something important. We put huge effort to make sure to test each release but due to the nature of GNS3 we cannot possibly test all the scenarios, environments, images etc.

Windows

  • Close GNS3
  • Backup your projects
  • Download the 2.0 from the GNS3 website
  • Install it on top of current installation, no need to uninstall previous versions

If you use the GNS3 VM you need also to upgrade it, please read the GNS3 VM section of this document.

Video tutorial

Mac OSX

  • Close GNS3
  • Backup your projects
  • Download the 2.0 from the GNS3 website
  • Install it on top of current installation, no need to uninstall previous versions

If you use the GNS3 VM you need also to upgrade it, please read the GNS3 VM section of this document.

Linux

Ubuntu / Debian from 1.5

If you use the official packages just run:

sudo apt-get update
sudo apt-get upgrade

Ubuntu / Debian from 2.0 release

First you need to uninstall GNS3 to switch to the stable channel.

sudo apt-get remove gns3-server gns3-gui

Next remove the unstable repository:

sudo add-apt-repository --remove ppa:gns3/unstable

And clean package cache:

sudo apt-get clean

And install the stable version from the stable channel:

sudo add-apt-repository ppa:gns3/ppa
sudo apt-get update
sudo apt-get install gns3-gui

GNS3 VM

WARNINGSnapshot the VM before. In case of issue you can rollback using the snapshot.

Start the VM.

Click OK on the information screen:

Choose version

And 2.0

The text can be different if you come from an older VM. If you don’t have the 2.0 option run Upgrade from the previous menu.